Installing Geosoft python package for Python 3.6

Hi, I'm trying to get python working with Oasis Montaj, following the instructions from here... https://geosoftgxdev.atlassian.net/wiki/display/GXDEV91/Installing+GX+Developer

I've installed the latest Anaconda package as stated in the instructions, but then when i came to install the Geosoft python package I get this:
C:\Users\sc>python.exe -V
Python 3.6.0 :: Anaconda 4.3.1 <64-bit>
C:\Users\sc>c:\ProgramData\Anaconda3\Scripts\pip.exe install geosoft
Collecting geosoft
Could not find a version that satisfies the requirement geosoft (from versions: )
No matching distribution found for geosoft

Checking here (https://pypi.python.org/pypi/geosoft) is looks to me there are only versions for python 3.4 and 3.5? Is that right, or am I doing something wrong? If so, do you recommend stripping Anaconda and finding an old version with 3.5, or is there any other way? Thanks, Sam.

Comments

  • Hi Sam,

    Our next release will have Python 3.6 support. This should be available soon (likely within the next 2 weeks). In the mean time you could do one of 3 things:

    1. Use a distribution with Python 3.5
    2. Add a conda VirtualEnv with Python 3.5 (https://conda.io/docs/using/envs.html)
    3. Use setup.py install with our 9.2 pre-release from: https://github.com/GeosoftInc/gxpy/releases

    Note that some API calls will not be available when using the 9.2 pre-release with the current released versions (9.1 or older) of Oasis montaj.

    Cheers,
    Jacques
  • Ok, Thanks Jacques.
This discussion has been closed.