Question about GX Developer/cpp/lib

tedye
edited March 2017 in GX Developer
Hello,
My environment: GX Developer9.1+Visual Studio 2015+Oasis montaj8.4
I want to build a dll program,and use gx to call the dll to create a database in oasis.
I set the vs->program properties->VC++ Directories->Include Directories->gx developer\cpp\include;
vs->program properties->VC++ Directories->Library Directories->gx developer\cpp\lib;

And I include the headfiles:
include gx_define.h
include gx_lib.h
include gx_extern.h


When I finished all my code and built it,it came some errors,such like:
error LNK2019: unresolved external symbol [email protected] referenced in function "int __cdecl GDBCreate(int,char *,double *,double *,double *,double *,double *,bool,int,double *)" ([email protected]@[email protected])

PS:Before this,I used another computer,its environment: GX Developer8.1+Visual Studio 2008+Oasis montaj8.02
On my old computer,i can build it successfully.

The same setting,the different result....
what can i do for this? I'm sure my code is all right,and my setting is all right...



Best regard.



Tagged:

Comments

  • Hi,

    I believe that GX developper and Montaj shoud be at the same version as in you older computer.

    Also version 9.x is 64 bit and 8.x is 32 bit, I don't think this will be a good mix...


  • Hi,

    I believe that GX developper and Montaj shoud be at the same version as in you older computer.

    Also version 9.x is 64 bit and 8.x is 32 bit, I don't think this will be a good mix...


    thanks for your help. but i change for the old version gx developer lib,it didn't works.

    I think have to mention that I just meet the problem at my program buildiing time,not running in the oasis. so it's the problem about the vs2015 linking of gx developer function in the lib....

    so what should i do ? please.

    best regards.
  • I saw the gx developer discription,but I failed to know what the lib's version is?
    are the libs' version is X64?
    OK,if I use the api in the geogx.lib, Visual studio always comes the error:
    link2019:The linker could not find a definition for external symbol "symbol" used in function "function".

    such as:LINK2019:The linker could not find a definition for external symbol "[email protected]" used in function "function".

    LINK2019:he linker could not find a definition for external symbol "_Create_VM" used in function "function".

    I just want to know how to set my visual studio to link the lib.
    PS:I swear my setting of lib and include is all right.

    best regard.

  • Hi,

    I believe that GX developper and Montaj shoud be at the same version as in you older computer.

    Also version 9.x is 64 bit and 8.x is 32 bit, I don't think this will be a good mix...


    Hello,thank you very much!!!I got it!!!
    I set my visual studio program's plat at x64,and I built it successfully.
    another problem is coming:
    My oasis vrsion is 8.4,so I can't use the dll I built...
    what can I do ?
    how can I get the old gx developer? or how can I update my oasis?

    PS:my oasis' certification is valid.

    Best regards.
This discussion has been closed.