Vein modelling weirdness

I have raised the following issue with Seequent Support and received a 'fix' of sorts but no explanation as to the cause and apparently no other users have reported anything similar. So I'd like to know if anyone else has come across this bug in vein modelling.
LF version 2021.1.3: I had a set of vein intercepts defined by a selection column in a merged interval table. I created a new geological model with Base Lithology set as the selection column. When I created a new vein with pinch-outs the resulting modelled shape passed through drill holes that didn't contain the corresponding vein code. Even if I coded the remainder (non-vein) parts of all drill holes with a dummy no vein code the model still pushed through drill holes it shouldn't have, although pinch-outs did occur in some holes.

The attached picture shows a blue modelled vein that should only be passing through drill holes containing the blue code and the circled area shows where the vein is modelled through holes where it doesn't occur. Note that in part of the model the pinch-out works as it should. I ran the same model with everything that wasn't the blue code assigned the same dummy 'no vein' code with the same result. This is one of 8 vein codes in my data and all did the same thing. 

Now for the really weird part: when I re-saved the project and cut out some un-necessary parts to send to Support to have a look at, the resulting refreshed models seemed to fix themselves and behave properly. However, when I deleted and re-generated the models the same problem appeared again. The original model is still not working as it should, regardless of how many times I refresh or re-generate the models.  

The support fix involved manually inserting polylines to control the hangingwall/footwall trends and force a pinch-out, but to me this is somewhat unsatisfactory and doesn't really explain what might be happening. 

If anyone else has had this happen, please let me know along with any solution you found.

cheers

James Lally
Tagged:

Comments

  • KennethMontero
    edited December 5
    Hello James,
    I have also had the same problem with pinch-out vein modeling, however, I have found a way to solve the problem without adding polylines.
    It appears that vein modeling has this problem when the program needs more segments to interpolate at the edges of the vein. I show you an example in the attached figure.
    In this case I had the same problem and the solution was to add some extra segments at the edges of the grain to guide the interpolation. Another solution that has worked for me is to edit the HW or FW of the outer segments of the vein to control their shape so that this problem does not happen.
    Cheers

  • Thanks for the response Kenneth. Can you clarify what you did in the example? it looks like you added an intercept into one of the drillholes in the bottom figure that's not in the top. Did you raise a support ticket for this by the way? From my interaction with Support it seemed liked no-one else has reported anything similar, which made me start questioning my sanity! There is presumably some particular confluence of factors causing the error, which is why it's not more widely reported. Otherwise it's just me.