Unable to install Geosoft Viewer Release 9.9.1 - January 2021

Hi, 
I am unable to install Geosoft Viewer Release 9.9.1 - January 2021
on a PC with W10 64bits.
I got the following error message during the install process: "Failed to download: http://updates.geosoft.com/Prereq/VCRuntime/VC2008.EXE".
Any solution for this case?
Thank you.
Best regards,
Richard

Comments

Categories