Error using copyline.gx in gs script in Oasis version 9.6

Currently revisiting some gs scripts that were written in Oasis 9.3.2, that were used to import magnetometer data.

The script includes the copyline.gx, however when run produces an error (see attached image) saying that the gx was built for an earlier version of Geosoft montaj (I am running 9.6).


This is especially strange as if the standard method of copying a line in Oasis montaj is followed: Database tools > Line Tools > Copy Line (while recording a script), the saved script is something similar to the below:

/-------------------------------------------------------------------------
/ LOG OPENED : Mon Sep 02 15:20:36 2019
/-------------------------------------------------------------------------
CURRENT Database,"r:\Projects\Live\p7051-19 geotechnical uxo ltc package a\Oasis\P7051-19 MAG.gdb"
SETINI COPYLINE.IN="LP7051_Mag_190829_R1_MAG1"
SETINI COPYLINE.IN="LP7051_Mag_190829_R1_MAG1"
SETINI COPYLINE.OUT="LP7051_MAG_190829_R1.1"
GX copyline.gx
/-------------------------------------------------------------------------
/ LOG CLOSED : Mon Sep 02 15:20:48 2019
/-------------------------------------------------------------------------

Note the copyline.gx (it would appear Oasis 9.6 does recognise the copyline.gx after all?)


Would greatly appreciate some assistance on this, as to why the copyline.gx command isn't working in my script?
Is there an updated version of the copyline.gx that I am somehow missing?

Many thanks in advance
Tagged: